MADEKnowledge

MADE Module Guides > MADE Module User Manual (Functional Modeling & Failure Definition)

3 System Creation

System creation in MADE requires creating a new project, and creating or importing items such as systems, subsystems, components or parts to make up a desired system. This is primarily conducted in the MADE Modelling module.

MADE Modules

The MADE software is currently divided into 4 modules:

  1. MADE – Maintenance Aware Design Environment. The MADE module is used to create systems using FBDs, assess system dependencies and simulate failure responses.
  2. SRA – Safety and Risk Assessment. The SRA module is used to edit and assess system criticality.
  3. RAM – Reliability, Availability & Maintainability. The RAM Module is used primarily to conduct reliability and maintenance-related analyses such as Reliability Allocation, RBD analyses, Reliability Centered Maintenance and others.
  4. PHM – Prognostics and Health Monitoring. The PHM Module is used to conduct sensor trade-off analyses and optimization of system sensors. This manual focuses on the MADE module.

Users can select modules in the following ways:

  • Selecting the module icon from the icon menu (Figure 3), or
  • Selecting: View > Open Module > [Module] from the main menu (Figure 4), which lists MADE, SRA, RAM, PHM.

3.1 Create a New Project

A new project acts as a blank template for system generation. To create a new project:

  • Select File > New from the main menu. After this, a project wizard will appear.

New Project Input Details

Enter the new project information as required. An explanation of each term is listed below.

Table 1: New Project Detail Definitions

Field Description
Project Directory By using the Browse button, the user can select the location in which the project directory will be created.
Project Name The project name entered will be used when a new MADE file is automatically created.
System Name This name is assigned to the system which forms the highest level of indenture in the system model.
Analyst Name This is the name of the MADE user and will be displayed in the project properties.
Organization This is the name of the organization of the MADE user and will be displayed in the project properties.
Currency Selecting the currency type will set the currency for all cost-related analyses in MADE.

The New Project dialog (Figure 6) shows fields: Project Directory, Project Name, System Name, Analyst Name, Organization, Currency, with example values Project Directory = "C:\Windows", Project Name = "Example Project", System Name = "Vehicle System", Analyst Name = "CS", Organization = "PHMT", Currency = "$ (AUD) - Australian Dollar". Buttons: Finish, Cancel.

New Project Troubleshooting

An incorrect project directory path will result in an error warning with the accompanying text Please enter a valid directory name in the New Project Wizard. Until this directory path is changed, the user will not be able to select Finish and create the MADE project.

After selecting Finish, the Project Explorer viewer (top-left) will display the system name.

3.2 Import from Another MADE Project

The Import feature allows previously built systems, subsystems, components, parts and their accompanying information to be imported into a currently opened MADE project. To do this, select:

  • File > Import from the main menu

Selecting import from the main menu will open the Import Wizard where a file path can be selected to load a MADE file (accepted file types: *.made; *.STEP; *.STP; *.xlsx).

After selecting a compatible MADE file and selecting Next the Import wizard will show the Import Project Explorer (left) and the Current Project Explorer (right). The Import Project Explorer section shows the selected MADE project and displays its project explorer tree structure. The Current Project Explorer displays the project tree for the currently opened project.

To complete the import of items:

  • Select (Left-click) and drag the desired item to import from the project tree.
  • Drag-and-drop the selected item to the desired location on the right (e.g. Power Generation Subsystem).
  • If the current project has multiple levels of indenture, the user can drag and drop the selected item to other levels of indenture. To do this, the user must first expand the tree diagram by selecting the arrow icons.
  • A successful import will show a highlighted in blue level of indenture and display a plus sign. A copy of the selected item will be placed on the indenture where it was dropped.
  • Select the next item to import or Finish to complete the import.

Figure 10 ("MADE Import File Wizard. Power Generation Subsystem transferred into the Vehicle System") shows the Import MADE Components dialog: left tree "Import Project Explorer" with items including Wheel Front, Wheel Rear, Wheel Resistance Front, Wheel Resistance Rear, Power Generation (highlighted, being dragged), Control Unit, Diesel Engine > Air Filter, Coupling 1, Engine, Governor, Injector Pump, Lift Pump, Primary Fuel Filter, Secondary Fuel Filter, Fuel Tank > Inlet, Lining, Outlet, Vehicle; right tree "Current Project Explorer" showing "Vehicle System" as the drop target with a drag cursor indicator.

Users can select the Undo or Redo arrow buttons (bottom left) to undo or redo an import action. Once the Finish button is selected, imported items will be shown in the Project Explorer.

3.3 Creating a Model Item

3.3.1 Opening the System Model

The most basic items of a MADE model consist of subsystems, components, and parts. Before any of these items can be created, the System Model editor must first be opened. To open the System Model:

  • Select (Right-click) the Vehicle System in the Project Explorer
  • Select System Model from the right-click menu

After this selection, the System Model editor will appear on the center of the MADE program. The system model editor consists of the following features:

  • A tab to the top left allowing the user to manipulate the editor placement
  • Display text in the top left showing the end effect and current analysis applied
  • Minimize and Restore buttons on the top right corner
  • A blank system model with two MUX bars that are the functional boundaries of the system

3.3.2 Creating a New Item

A new item can be created in several ways:

  1. From Diagram > New > [item] in the main menu
  2. From the icon menu. Hovering highlights the tooltip Add New [Item]
  3. From within the system model: Select (right-click) a blank space in the system model, then select New → [Item] from the right-click menu
  4. From the Project Explorer by selecting (right-click) an item e.g. System and selecting New > [Item] from the right-click menu

New item types available: Part, Component, Subsystem.

Note: The System Model editor must be active for these options to be available in MADE.

3.3.3 Renaming an Item

Once items have been created, they can be renamed individually or by batch using several methods:

  1. Select the item from the Project Explorer (left-click twice with a 1 second delay between clicks) – item name will be highlighted in grey allowing the user to retype its name directly
  2. Select an item from the System model then select the Properties Viewer then select the Item Name field under the General tab
  3. Select Search > Find / Replace from the main menu
  4. Right-click on an item and select Advanced Properties – In Overview page select the Item Name text field to rename the item

The Properties Viewer for a renamed item ("Fuel Tank") shows tabs: General, Bond, Functional Failures, Technical Property. The General tab shows: Item Name, Item Number, Physical Description; a Logistics section with LCN; a Criticality Flag section with checkboxes Critical Item, Mission Critical, Safety Item, Loss of System; a Maintainability section with checkboxes LRU, SRU and a Group dropdown (default "None").

Source: Local MADE 3.9.1 installation: com.phm.made.help.plugin/documents/help/pdf/MADE Module User Manual.pdf · retrieved 2026-07-09