MADEKnowledge

MADE 3.9.1 User Manual > Modelling > Dynamic Modelling

Bond Graph Simulation: Analysis Actions

Actions associated with Bond Graph simulations & modelling are listed below:

View Bond Graphs

To view Bond Graphs in the Bond Graph editor:

  1. Right-click the System in Project Explorer (or any area of the System Model editor)
  2. Select "Bond Graph" from the menu

[Image: bondgraphmenu.png]

[Image: samplebond.png]

Verify Causality

Causality establishes the cause and effect relationships between the factors of

power.

Causality of a bond graph model is automatically verified after the bond

graph is generated in the Bond Graph editor.

Note: MADE only displays causality errors in the bond graph (highlighted

in red) and Problems viewers (as errors e.g. 'Causal strokes do not match the bond

group assigned to [Bond Type][Item]'). A bond graph with correct causality can be

confirmed when there are no errors displayed in the system model and problems

viewer.

To verify & fix a causality error:

  1. Open the Bond Graph editor and note any bond types highlighted in red
  2. Select the Problems viewer
  3. Expand the Errors tab to view descriptions of each causality error
  4. Change the Bond Type for highlighted items in the Bond Graph editor using the Properties Editor
  5. Repeat until all causality errors disappear

[Image: CausalityProblems.png]

[Image: CausalityProblems2.png]

Verify Controllability

Controllability describes the ability of an external input to move the internal

state of a system from an initial state to any final state in a finite time

interval. Controllability does not mean that a reached state can be maintained,

merely that any state can be reached.

Controllability is automatically verified when a Bond Graph is generated in the

Bond Graph editor.

To automatically verify controllability of a bond graph model:

  1. Ensure there are no errors in the "Problems" view
  2. Open the Bond Graph editor and note any bond types highlighted in red
  3. View the top-left corner of the bond graph editor - a controllable model will display 'Bond Model is Controllable'.

[Image: Controllable.png]

[Image: Controllable2.png]

To manually verify controllability of a bond graph model:

  1. Right-click the canvas of the bond graph editor
  2. Select "Verify Controllability" from the menu
  3. Verify that the pop-up dialog shows that the "[System Name]" is controllable

[Image: Controllable3.png]

[Image: Controllable4.png]

View Equation Set

The equation set displays a list of automatically generated equations derived

from a bond graph. It consists of a numbered list of equations, where each equation

lists a unique identifier of a causal stroke and associated bond type(s).

To view Bond Graph equations:

  1. First very that Bond Graph causality is valid
  2. Select Equation Set from the main menu under View > Open View > Equation Set

Note: If causality is incorrect, system equations will not be

generated.

The equation sets can be viewed as a Table (flat list) or in system tree

(similar to the project explorer) using a toggle button located at the top right

corner of the viewer.

[Image: btnTreeView.png]

Table view

Bond Graph equations listed in the table are in order of simulation sequence.

[Image: propertiesEquationsTable.png]

System Tree view

Equations are grouped by item hierarchy (similar to Project Explorer).

[Image: propertiesEquationsTree.png]

Bond Graph Equation Notations:

The examples below show the basic format of equation elements generated from a

Bond Graph:

  • [Causal Stroke ID].[Bond Type] e.g. 1.Inductance, 2.Effort, 3.Capacitor State
  • [Math Operator][Causal Stroke ID].[Bond Type] e.g. Integral (7.Flow)

Each Bond Graph equation consists of a source item (bond type), a target item

(bond type) and additional passive variables (if relevant). See examples below:

Bond[SourceComponent.Element--TargetComponent.Element].Variable

  • [Causal Stroke ID][Source Item Bond Type]=[Causal Stroke ID][Target Item Bond Type] e.g. 23.Effort=17.Effort
  • [Causal Stroke ID][Source Item Bond Type]=[Operator][Causal Stroke ID] [Target Item Bond Type] e.g. 5.Capacitor State = Integral(5.Flow)
  • [Causal Stroke ID][Source Item Bond Type]=[Causal Stroke ID][Passive Variable][Operator][ID][Bond Type][Operator][Passive Variable] e.g. *8.Flow = 8.Inductor State / 8.Inductance + Inductor initial condition *

View Simulation Responses

The simulation response graph is used to model the behaviour of an item, bond

type or flow property in a system (including situations where a failure is

introduced) in a graphical format.

There are 3 types of failure injection options: "Up",

"Down", and "Perturb by Value". The availability of these

failure responses are based on the settings in the Failure Injection editor in the

Properties Viewer.

To generate and view a simulation response graph for individual items/flow

properties:

  1. Ensure system causality is valid (incorrect causality will result in an empty graph)
  2. Optional: Enter a failure injection (right-click item/bond graph item > select failure injection > flow property > failure response)
  3. Right-click an item/bond type/causal stroke from the system model or bond graph editor
  4. Select Response Simulation > Flow Property/Bond Type

[Image: responsesimmenu.png]

[Image: simResponseView.png]

The Response Simulation viewer contains 4 icons in the top-right corner:

  1. Simulate Refreshes the simulation response when a change is made to the system. [Image: btn_normalize.gif]
  2. Normalize normalizes the simulation graph for y value to lie between values -1 and 1 [Image: btn_normalize.gif]
  3. Maximize hides the equation set and only shows the simulation response graph [Image: btn_simulation_maximize.gif]

Generate Bond Graph Perturbations

To perturb all items in a bond graph:

  1. Ensure system causality is valid (incorrect causality will result in an empty graph)
  2. Right-click a blank area within the System Model diagram
  3. Select "Propagate All..." from the menu (Alternatively select the propagate icon from the icon menu [Image: btn_propagateAll.png]
  4. Select the Analysis Type (FCM or Bond)
  5. Select flows or flow properties of interest by selecting the check-box next to it
  6. Select "Propagate" to generate propagation and open Propagation Table viewer

[Image: propagateAllDialog.png]

To reset the Propagation Table to show nominal responses, select the reset

icon

[Image: btnReset.png]

located in the icon

tool bar.

Source: Local MADE 3.9.1 installation: com.phm.made.help.plugin/documents/help/html/MADeHelp/03-Modelling/03-03-DynamicModelling/03-03-08-DynamicActions.html · retrieved 2026-07-09